海薇站长网 - 让网站建设、优化、维护从此简单!

海薇站长网

当前位置: 海薇站长网 > CMS教程 > 织梦cms内容页自动内链在PHP5.5以上版本不能用

织梦cms内容页自动内链在PHP5.5以上版本不能用

时间:2018-04-20 10:45来源:CMS教程网 作者:365天天网 点击:
织梦cms在php5.5+中,由于php5.5以后规定preg_replace必须被替换成preg_replace_callback,而天涯只在代码中留下了一句“这里可能会有错误”就不了了之了(事实不是可能有错误,而是就是有错误)。

织梦DEDECMS在PHP版本高于5.5的情况下无法使用关键词內链的解决方法:

相信很多用DedeCMS的站友们都会为给文章做内链觉得繁琐,对于很多插件可能是实现,但很多都需要花钱买,对于很多草根站长花这钱也不值,小编我因学过PHP程序,索性就研究起这问题了,终于再花了4个小时的研究对程序稍作修改实现了该功能,不多说我们开始操作吧

织梦cms在php5.5+中,由于php5.5以后规定preg_replace必须被替换成preg_replace_callback,而天涯只在代码中留下了一句“这里可能会有错误”就不了了之了(事实不是可能有错误,而是就是有错误)。导致织梦功能中的文档关键字自动替换的功能无法使用。本文档就是解决织梦dedecms文档关键字(自动内链)php5.5以上失效的问题。下载本文档解压后,直接覆盖到include文件夹即可。后台的替换数等均可正常使用。

打开/include/arc.archives.class.php 找到:

version_compare(PHP_VERSION, '5.5.0'

替换成:

version_compare(PHP_VERSION, '7.5.0'

共有两处。然后再看看。

(责任编辑:365天天网)
顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
表情:
用户名: 验证码:点击我更换图片
推荐内容
意见反馈 站长网首页 返回顶部